系统小窝欢迎您

当前位置:系统小窝 > 系统教程 > Linux教程 >

使用Quagga软件配置CentOS设备的方法详解

时间:2021-04-09    来源:来了老弟    人气:

Quagga是一款路由软件,能够将Linux设备打造成路由器,实现强大的真正路由器功能,那么具体该怎么做呢?下面随小编一起来了解下如何使用Quagga配置CentOS设备的方法。

Quagga支持几种主要的路由协议,比如RIP、OSPF、BGP或ISIS路由器。它完全为IPv4和IPv6作好了准备,还支持路由/前缀过滤。万一你生产环境中的路由器出现了故障,手头又没有备用的路由器,死等替换件送来,Quagga就能派得上大用场。只要配置得当,Quagga甚至可以配置成生产环境中的路由器。

我们在本教程中将连接两个假设的分支机构网络(比如192.168.1.0/24和172.17.1.0/24),这两个网络之间采用了一条专用的链路。

我们的CentOS设备位于这条专用链路的两端。这两个设备的主机名称分别被设为;site-A-RTR;和;site-B-RTR;。下面提供了IP地址的信息信息。

Site-A:192.168.1.0/24

Site-B:172.16.1.0/24

两个Linux设备之间的对等:10.10.10.0/30

Quagga软件包含有几个协同运行的后台程序。我们在本教程中将着重介绍设置下列后台程序。

Zebra:核心后台程序,负责内核接口和静态路由。

Ospfd:IPv4 OSPF后台程序。

将Quagga安装到CentOS上

我们首先使用yum来安装Quagga。

# yum install quagga

在CentOS 7上,SELinux在默认情况下阻止/usr/sbin/zebra写入到其配置目录中。这个SELinux策略干扰了我们所要描述的安装过程,于是我们想禁止该策略。为此,关闭SELinux(不推荐),或者启用;zebra_write_config;布尔表达式,如下所示。如果你使用CentOS 6,可以跳过这一步。

# setsebool -P zebra_write_config 1

要是不进行这种更改,我们在试图从Quagga的命令外壳里面保存Zebra配置时,就会看到下列错误。

Canlsquo;t open configuration file /etc/quagga/zebra.conf.OS1Uu5.

(无法打开配置文件/etc/quagga/zebra.conf.OS1Uu5。)

Quagga安装完毕后,我们就配置必要的对等IP地址,并更新OSPF设置。Quagga随带一个名为vtysh的命令行外壳。vtysh里面使用的Quagga命令类似思科或瞻博等各大路由器厂商的那些命令。

第一个阶段:配置Zebra

我们首先创建一个Zebra配置文件,然后启动Zebra后台程序。

# cp /usr/share/doc/quagga-XXXXX/zebra.conf.sample /etc/quagga/zebra.conf

# service zebra start

# chkconfig zebra on

启动vtysh命令外壳:

# vtysh

首先,我们为Zebra配置日志文件。为此,输入下列内容,进入vtysh中的全局配置模式:

site-A-RTR# configure terminal

并指定日志文件位置,然后退出该模式:

site-A-RTR(config)# log file /var/log/quagga/quagga.log

site-A-RTR(config)# exit

永久性保存配置:

site-A-RTR# write

下一步,我们在必要时确定可用接口,然后配置IP地址。

site-A-RTR# show interface

Interface eth0 is up, line protocol detection is disabled

。 。 。 。 。

Interface eth1 is up, line protocol detection is disabled

。 。 。 。 。

配置eth0参数:

site-A-RTR# configure terminal

site-A-RTR(config)# interface eth0

site-A-RTR(config-if)# ip address 10.10.10.1/30

site-A-RTR(config-if)# description to-site-B

site-A-RTR(config-if)# no shutdown

继续配置eth1参数:

site-A-RTR(config)# interface eth1

site-A-RTR(config-if)# ip address 192.168.1.1/24

site-A-RTR(config-if)# description to-site-A-LAN

site-A-RTR(config-if)# no shutdown

 

现在验证配置:

site-A-RTR(config-if)# do show interface

Interface eth0 is up, line protocol detection is disabled

。 。 。 。 。

inet 10.10.10.1/30 broadcast 10.10.10.3

。 。 。 。 。

Interface eth1 is up, line protocol detection is disabled

。 。 。 。 。

inet 192.168.1.1/24 broadcast 192.168.1.255

。 。 。 。 。

site-A-RTR(config-if)# do show interface description

Interface Status Protocol Description

eth0 up unknown to-site-B

eth1 up unknown to-site-A-LAN

永久性保存配置:

site-A-RTR(config-if)# do write

针对site-B服务器,也重复IP地址配置这个步骤。

要是一切顺利,你应该能够从site-A服务器来ping检测site-B的对等IP 10.10.10.2。

请注意:一旦Zebra后台程序已启动,用vtysh的命令行接口进行的任何更改会立即生效。不需要在配置变更后重启Zebra后台程序。

第2个阶段:配置OSPF

我们先创建一个OSPF配置文件,然后启动OSPF后台程序:

# cp /usr/share/doc/quagga-XXXXX/ospfd.conf.sample /etc/quagga/ospfd.conf

# service ospfd start

# chkconfig ospfd on

现在启动vtysh外壳,继续进行OSPF配置:

# vtysh

进入路由器配置模式:

site-A-RTR# configure terminal

site-A-RTR(config)# router ospf

还可以手动设置router-id:

site-A-RTR(config-router)# router-id 10.10.10.1

添加将参与OSPF的网络:

site-A-RTR(config-router)# network 10.10.10.0/30 area 0

site-A-RTR(config-router)# network 192.168.1.0/24 area 0

永久性保存配置:

site-A-RTR(config-router)# do write

针对site-B,也重复类似的OSPF配置:

site-B-RTR(config-router)# network 10.10.10.0/30 area 0

site-B-RTR(config-router)# network 172.16.1.0/24 area 0

site-B-RTR(config-router)# do write

OSPF邻居现在应该会出现。只要ospfd在运行,通过vtysh外壳所作的任何与OSPF有关的配置变更都会立即生效,没必要重启ospfd。

在下一个部分,我们将验证已安装的Quagga环境。

验证

1. 用ping来测试

首先,你应该能够从site-A来ping检测site-B的局域网了网。确保你的防火墙没有阻止ping检测流量。

[root@site-A-RTR ~]# ping 172.16.1.1 -c 2

2. 检查路由表

内核和Quagga路由表里面应该都有必要的路由。

[root@site-A-RTR ~]# ip route

10.10.10.0/30 dev eth0 proto kernel scope link src 10.10.10.1

172.16.1.0/30 via 10.10.10.2 dev eth0 proto zebra metric 20

192.168.1.0/24 dev eth1 proto kernel scope link src 192.168.1.1

[root@site-A-RTR ~]# vtysh

site-A-RTR# show ip route

Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,

I - ISIS, B - BGP, 》 - selected route, * - FIB route

O 10.10.10.0/30 [110/10] is directly connected, eth0, 00:14:29

C》* 10.10.10.0/30 is directly connected, eth0

C》* 127.0.0.0/8 is directly connected, lo

O》* 172.16.1.0/30 [110/20] via 10.10.10.2, eth0, 00:14:14

C》* 192.168.1.0/24 is directly connected, eth1

3. 验证OSPF邻居和路由器

在vtysh外壳里面,你可以检查必要的邻居有没有出现,是否记住合适的路由。

[root@site-A-RTR ~]# vtysh

site-A-RTR# show ip ospf neighbor

通常来说,Quagga让我们很容易配置普通的Linux设备,以便支持OSPF、RIP或BGP等动态路由协议。支持Quagga的设备能够与你网络中可能拥有的其他任何路由器进行联系、交换路由。

由于Quagga支持几种主要的开放标准路由协议,它在许多场景下可能是优先的选择。更棒的是,Quagga的命令行接口与思科或瞻博等各大路由器厂商的命令行接口几乎一样;这样一来,部署和维护设备Quagga设备就显得非常容易。

上面就是Quagga软件配置CentOS设备的方法介绍了,你可使用命令配置或直接修改配置文件来实现,智能而又方便,基本不需要用户再设置静态路由,赶紧试试看吧。

相关文章

  • CentOS系统如何把IP从Fail2ban黑名单中移除

    CentOS系统如何把IP从Fail2ban黑名单中移除

    CentOS系统中Fail2ban是一款保护服务器免受网络攻击的工具,Fail2ban可以通过黑名单来禁止IP访问。既然有被禁止的IP,那么问题来了,CentOS系统如何把IP从Fa...
    2021-04-09 03.04.14
  • CentOS安装内核头文件的操作方法

    CentOS安装内核头文件的操作方法

    很多用户想在CentOS上安装内核投文件,其实安装方法很简单,但是在安装之前应该先查看下系统当前的内核版本,版本一样可直接安装,若版本不一样则需...
    2021-04-09 03.04.12
  • CentOS下telnet退出失败的解决办法

    CentOS下telnet退出失败的解决办法

    最近有CentOS用户反映在调试网络程序时出现了问题,服务虽然启动了,但客户端却无法连接上,用telnet连接后发现是Windows防火墙的问题,可是用telnet命令连...
    2021-04-09 03.04.54
  • Linux(CentOS)如何安装DNS服务器?

    Linux(CentOS)如何安装DNS服务器?

    DNS其实就是系统上的一个占用53端口的服务,用来提供域名和IP地址的相互转换。比如你访问ip.gs,路由器是不可能知道这个地址,你需要先连接到DNS服务器...
    2021-04-09 03.04.24
  • Linux CentOS系统要怎么安装?Linux CentOS系统安装方法教学

    Linux CentOS系统要怎么安装?Linux CentOS系统安装方法教学

    Linux CentOS系统要怎么安装?Linux系统作为一款免费开源的电脑操作系统,许多用户也十分的喜爱这款系统。而对于一些电脑小白来说,Linux系统十分的不友好...
    2021-04-09 03.04.58

发表评论

验证码: 看不清?点击更换

注:网友评论仅供其表达个人看法,并不代表本站立场。